Categories
Windows

How to fix Valorant “This build of Vanguard requires TPM version 2.0 and secure boot to be enabled” error

Ultimate step by step guide.

Valorant is a very popular game, played by a lot of users worldwide. But often the fun gets disrupted by showing error. Among many errors, one common error is “This build of Vanguard requires TPM version 2.0 and secure boot to be enabled”. Read on for the fix.

What is Valorant?

Valorant is a free-to-play first-person shooter for Microsoft Windows developed and published by Riot Games.

In October 2019, the game was first announced under the codename Project A, then on April 7, 2020, it launched a closed beta period with limited access, followed by an official release on June 2, 2020.

How to fix Valorant “This build of Vanguard requires TPM version 2.0 and secure boot to be enabled” error.

To fix this error you need to enable TPM 2.0 in BIOS of your PC.

To Enable TPM version 2.0 follow these steps:

  1. Restart or shut down your PC, while restarting press BIOS key
To Enable TPM version 2.0 follow these steps -1

2. BIOS key depends on the manufacturer of your computer. Here is some of most common brands BIOS key.

Brand BIOS Key
ASUSF2
MSIDel
HPF10
DellF2 Or F12
GigabyteDel
BIOS key of hp, dell and asus pcs.

3. Go to ‘Advance’ option.

4. Click on ‘Settings’.

5. Click on ‘Security’ option.

6. Open ‘Trusted Computing’.

7. Enable ‘Security Device Support’.

8.Then you have to select the TPM switch, it will be in name of processor (intel TPM, AMD TPM) and you have to select that option.

How To Enable Secure Boot in Windows 10 and Windows 11

  1. Go back to ‘Settings’, open ‘Advanced’ and click on ‘Windows OS Configuration’.
  2. In the following page, you will see BIOS mode, make sure its in UEFI mode.
  3. On the same page, you will see option of Secure Boot, click on it and Enable it.